Discussion Forums - Questions about PaperBackSwap Questions about PaperBackSwap

Topic: What's With the Wish List Search?

Club rule - Please, if you cannot be courteous and respectful, do not post in this forum.
  Unlock Forum posting with Annual Membership.
Subject: What's With the Wish List Search?
Date Posted: 1/24/2010 11:21 PM ET
Member Since: 2/28/2008
Posts: 2,553
Back To Top

Maybe it's just me, but I have NO luck searching my wishlist. I will know a book is on there, but don't want to scroll the pages, so I type in the title in the WL search bar on my WL page and EVERY TIME there is NO results. It doesn't matter what I search. Title, author, both, I always get no results. Anyone else have this problem or is there just something major I'm missing here?

Date Posted: 1/24/2010 11:23 PM ET
Member Since: 8/16/2007
Posts: 15,194
Back To Top

It hasn't worked for a long time. I think I sent in feedback mid-Nov and they sent back that they were working on it.

Date Posted: 1/24/2010 11:27 PM ET
Member Since: 2/28/2008
Posts: 2,553
Back To Top

Well that's good to know, that it isn't just me that is. I was weirded out cause my reminder list search works just fine :P

Date Posted: 1/25/2010 8:37 AM ET
Member Since: 8/23/2007
Posts: 26,510
Back To Top

I have similar problems with my TBR and RL as well as the WL.  I'll see the little blue notice that a book is on my TBR or RL but when I search it'll say it's not there. Then I have to guess what page it might be on and search for the book. 

Date Posted: 1/25/2010 8:52 AM ET
Member Since: 6/26/2006
Posts: 6,633
Back To Top

The wish list search works for me, but I've noticed an odd quirk with it.  Typing in a search term and hitting "enter" (or "return") with my keyboard doesn't work.  If I type in the search term and use my mouse to click "search", the search works just fine.

Date Posted: 1/25/2010 12:32 PM ET
Member Since: 11/5/2009
Posts: 1,083
Back To Top

CTRL-F search works for me.  The Search box at the top of the page also works for me.  Perhaps the problem is that you have a long wish list on several pages.  If you are trying to search for something that is not on the page you are on, it won't find it.  At least that's how it works with CTRL-F.  I don't know if the same applies for their Search box.

You can test it by searching for a book name that is on the first page of your wish list. 

Date Posted: 1/25/2010 12:43 PM ET
Member Since: 5/18/2007
Posts: 13,193
Back To Top

Mine works most of the time. You just have to remember to hit the actual "search" button and not "enter" on your keyboard. (And it does search the entire wishlist, not just the page).

Occasionally mine won't work, however. There is some sort of weird glitch with it that has been mentioned from time to time on the forums. 

Date Posted: 1/25/2010 1:23 PM ET
Member Since: 1/17/2009
Posts: 9,854
Back To Top

I was told that it has something to do with the browser (I am on IE 7). My Wish List search hasn't worked ever since they made the changes to the Wish List. I had used it regularly before that, so, its been kind of annoying. All my other search buttons work fine ... TBR, bookshelf, Reminder List, etc.

I also had sent in feedback and they said they are working on it.

Date Posted: 1/25/2010 8:43 PM ET
Member Since: 6/19/2008
Posts: 5,700
Back To Top

I had that same thing happen, I thought it was just me ,that I was doing something wrong.......Which ,  with me is 9 times out of 10 the case...lol

Date Posted: 1/25/2010 8:54 PM ET
Member Since: 4/7/2008
Posts: 15,690
Back To Top

Ditto to the business of hitting enter vs. clicking search...the first one doesn't work, the second one does.

Also books on hold don't show up, no matter how you search for them....

Date Posted: 1/25/2010 9:00 PM ET
Member Since: 6/21/2007
Posts: 2,015
Back To Top


Last Edited on: 2/3/15 6:22 PM ET - Total times edited: 1
Date Posted: 1/26/2010 12:37 AM ET
Member Since: 11/14/2005
Posts: 6,421
Back To Top

Thanks very much for the tip of using the button instead of the enter key. I've been so frustrated that the search on the WL has been broken for so long. Now I know different! Paid to read the forums again :)

Date Posted: 1/26/2010 1:40 AM ET
Member Since: 2/26/2009
Posts: 36,023
Back To Top

Yea,  had the same problem on my RL...  actually ordered a book I thought I had on my Rl that wasn't, only to find after I received it that I DO have a copy... it just didn't show up on the RL when I searched for it.

Date Posted: 1/26/2010 5:02 AM ET
Member Since: 1/19/2008
Posts: 14,777
Back To Top

i use Firefox, and searching works fine for me - as long as i remember to use the button.  ever since they moved the WL search to the top of the WL page instead of popping up it's only little screen i almost always have to do it twice - because i hit enter the first time, and get the next page of my WL instead of it doing the search.  i haven't quite retrained my fingers yet not to hit the enter key.  :)

Date Posted: 1/26/2010 10:26 AM ET
Member Since: 2/28/2008
Posts: 2,553
Back To Top

I figured out the button vs enter thing a while ago, and when I did hitting the search button did work for me...once or twice. But now it doesn't work for me again. Like I said, the reminder list search works just fine (and thank god since my RL is HUGE lol).  I usually use IE but I'll try it with firefox see how that works for me.

Date Posted: 1/28/2010 12:42 AM ET
Member Since: 2/1/2008
Posts: 3,454
Back To Top

I haven't been able to search my WL in any way shape or form since they made the changes.  I was in the group of those that asked about this back in November.  (I actually started a thread about it here also)  I still can't search even if I do use the button instead of hitting enter and have to find my books by manually paging through my list.  TG there can only be 4 pages at a time to look through.  I just sort it alphabetically by title or author and try to guess which page the first letter will start on and go from there.

Date Posted: 1/28/2010 10:06 AM ET
Member Since: 5/10/2005
Posts: 2,357
Back To Top

Hold books don't show up on searches on WL.  This drove me nuts for a while before I figured it out (at the time not realizing they auto-held books when another version came available).

I sent in a bug report on it and they said they'd add it to their to-do but it'd be hard.  Now I try to keep my WL sorted so the hold books are at the top so I know if I have any!

Date Posted: 1/28/2010 10:07 AM ET
Member Since: 3/7/2009
Posts: 10,910
Back To Top

Yeah, the WL search just barely works for me.  I'm using Firefox and I always click the button instead of enter, but I still rarely get results or don't get the results I'm looking for.  For example, I have a book titled Secret Society on my WL.  If I type in "Secret," I get no results.

society.jpg

If I type in "Society," the book shows up.

secret.jpg

If I type in "Secret Society," I get three books, the one I'm looking for and two unrelated books that don't have secret or society in their titles, but do have both words (not necessarily together) in their descriptions. Going by that, all three of these books should have shown up on the first two searches because they have both words in their descriptions.

secretsociety.jpg

Date Posted: 1/28/2010 10:18 AM ET
Member Since: 6/25/2007
Posts: 5,637
Back To Top

It only works for me if I search using the full book title.  If I search by only the first word in the title, I'll get no results. I'm using FF on a Mac.

Date Posted: 1/28/2010 7:51 PM ET
Member Since: 4/28/2009
Posts: 1,258
Back To Top

I haven't had to search my WL very often because it's usually only one page long and I can just scroll down and find what I want, but I was curious what would happen after reading this thread.

So I tried a search to see if any of the problems popped up that were mentioned here and everything worked perfectly, any way that I tried it. 

I'm using Firefox on a computer and I can search my WL clicking the Search button, hitting enter, using any part of the title.

Isn't that weird?